dev.ed.am
sqlite3cc
Go to the previous open issue
Go to the previous issue (open or closed)
star_faded.png
Please log in to bookmark issues
icon_project.png sqlite3cc / Open Bug report #1 Update on row open in a query fails without error
action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
Go to the next issue (open or closed)
Go to the next open issue
Issue basics
  • Type of issue
    Bug report
  • Targetted for
    0.2 release
  • Status
    Closed
  • Progress
  • Priority
    Not determined
User pain
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
Affected by this issue (0)
There are no items
People involved
Times and dates
  • Posted at
  • Last updated
Issue details
  • Resolution
    CAN'T REPRODUCE
  • Reproducability
    Not determined
  • Severity
    Not determined
Attachments (0)
There is nothing attached to this issue
Duplicate issues (0)
This issue does not have any duplicates
Description
While iterating through the results of a query, an update against the row being iterated over fails (I assume because of row/table locking). But no error is thrown and the result code of the operation is that of a success!

If this is sqlite3's behaviour, then so be it, I guess. But it is not behaviour that sqlite3cc should exhibit otherwise.
Steps to reproduce this issue
<source lang="c++">// perform query
sqlite::query q( m_db,
"SELECT whatever "
"FROM table "
"WHERE id = ?" );
q << id;
sqlite::query::iterator i = q.begin();
if( i != q.end() )
{
// while query is open, perform update on same row
sqlite::command c( m_db,
"UPDATE table "
"SET whatever = 'whatever' "
"WHERE id = ?" );
c << id << sqlite::exec; // DOES NOTHING, BUT THERE'S NO ERROR
}</source>
Todos (0 / 0)
Issue created



To auto-link to an existing issue, write "issue", "bug", "ticket" or the issue type (like "bug report" or "enhancement") followed by the issue number (ex: "ticket #3" or "bug report MYPROJ-1"). Enclose sourcecode samples between two "~~~~" lines.
See more formatting tips in MarkdownFormatting.

To create a bulleted list, start one or more lines with a star ("* bulleted list item"). You can create a numbered list by using the hash/pund sign instead ("# numbered list item").
See more formatting tips in MarkdownFormatting.

Code samples are best presented in <source></source> tags. The Bug Genie can automatically apply syntax highlighting with support for over 100 languages! (<source lang="php"><?php echo "fu"; ?></source>)
See more formatting tips in WikiFormatting.

Cancel
I am unable to reproduce this error. In particular, if I compile the example program that you provided, it works just fine!

What version of sqlite3cc are you using?



Don't worry about URLs - they will automatically be transformed to links.
See more formatting tips in MarkdownFormatting.

The Bug Genie uses an enhanced flavor of the markdown syntax, which makes each newline count. If you want to add a linebreak, add a new line and it will be presented just like you type.
See more formatting tips in MarkdownFormatting.

You can use simple formatting tags for underlined text (<b></b>) or strikethrough (<strike></strike>).
See more formatting tips in WikiFormatting.

Cancel
The issue was updated with the following change(s):
  • The status has been updated, from New to Closed.
  • The resolution has been updated, from Not determined to CAN'T REPRODUCE.



To auto-link to an existing issue, write "issue", "bug", "ticket" or the issue type (like "bug report" or "enhancement") followed by the issue number (ex: "ticket #3" or "bug report MYPROJ-1"). Enclose sourcecode samples between two "~~~~" lines.
See more formatting tips in MarkdownFormatting.

To auto-link to an existing issue, write "issue", "bug", "ticket" or the issue type (like "bug report" or "enhancement") followed by the issue number (ex: "ticket #3" or "bug report MYPROJ-1"). Enclose sourcecode samples between two "~~~~" lines.
See more formatting tips in MarkdownFormatting.

If you want to put a horizontal line in the document, use four dashes: "----".
See more formatting tips in WikiFormatting.

Cancel
The issue was updated with the following change(s):
  • The milestone has been updated, from Not determined to 0.2 release.
footer_logo.png The Bug Genie 4.3.1 | Support | Feedback spinning_16.gif