dev.ed.am
Import Contacts
previous_open_issue.png
Go to the previous open issue
previous_issue.png
Go to the previous issue (open or closed)
star_faded.png
Please log in to bookmark issues
bug_report_small.png
icon_project.png Import Contacts / Closed Bug report #1 Crash during VCR import, facts and proposals
action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
next_issue.png
Go to the next issue (open or closed)
next_open_issue.png
Go to the next open issue
icon_info.png This issue has been closed with status "Closed" and resolution "RESOLVED".
Issue basics
  • Type of issue
    Bug report
  • Targetted for
    Not determined
  • Status
    Closed
  • Progress
  • Priority
    Not determined
User pain
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
Affected by this issue (0)
There are no items
People involved
Times and dates
  • Posted at
  • Last updated
Issue details
  • Resolution
    RESOLVED
  • Reproducability
    Not determined
  • Severity
    Not determined
Attachments (0)
There is nothing attached to this issue
Commits (0)
There are no code checkins for this issue
Duplicate issues (0)
This issue does not have any duplicates
Description
Hi,

I export from Nokia suite VCF files (near 200). The second step has been to put them into a folder of the smartphone (the flash card) using Air Android (can use too FTP).
The deadlock problem is that when I import to Android 4.0.3, I got a crash for some ones and I am no way to find a solution ,see farther.

At first import I could find the VCF file which had caused the crash, the cause was that the VCR was containing an image which seems not to be supported and the size of VCF was showing the differency.

As the import is not done alphabetically it not easy to find on which record the crash occurs.

I put away the image and the file had been imported.

But I could not go on farther and I have still a file or several ones which can and generates the crash, but which one I do not know.

I thought a moment that the crash was linked to encoding utf8 which is use for some imported VCF but it is not true because I have imported file with the encoding.

I tried to find common properties not treated file, no one, because the soft crashes on one into fifty, which one(s) generate or will generate a crash we don't know.

I repeat the treatment but I crashes again without new import.
Try to import file by file (or groups by dichotomy) can be a solution, but very long, it is a debugging step.

'''For a first step towards the solution''', I propose that an error treatment will avoid a full crash (stopping the soft) into the treatment of the VCF (because an error in syntax or a not supported feature of VCF is met). Then a message could tell which file and what has generated the problem (no more real crash).
Farther, the soft could skip the error or stop (classical option for all of such soft).
Farther : generate a log file ((ImportContact-(date)-nn.log) into the same directory as the source of VCF files.

For the moment I have near forty VCF that have not been imported and I can't unlock this, because I don't know what makes the soft crash.

Best regards

For reproduction step you will need to get my phonebook... but may be You found this problem before.
Steps to reproduce this issue
For reproduction step you will need to get my phonebook... but may be You found this problem before.
Comments ()
#1
 edam (edam)
Nov 14, 2012
Thanks for the report.

You haven't said which version of Import Contacts you are using, so I assume it is 1.1 (please correct me if this is not the case). I should start by explaining that I have done a lot more work on Import Contacts but the new version has not yet been released because of a significant bug that I need to work around first.

I'll try to address the issues you mentioned:
  • Images are not (yet) supported. But in the next version they will not cause Import Cntacts to fail. They're just ignored.
  • UTF-8 is handled very badly for v3 vCards. This is massively improved in the next version.
  • Error is improved in the new version. But a proper crash means there is a bug. Unfortunately you would need to try this with the latest code to see if it's still an issue, since the actual importing has changed so much.
  • I have added the logfile idea to the TODO list.


The issue was updated with the following change(s):
  • This issue has been closed
  • The status has been updated, from New to Closed.
  • The resolution has been updated, from Not determined to RESOLVED.
History