dev.ed.am
Arduino Makefile
Go to the previous open issue
Go to the previous issue (open or closed)
star_faded.png
Please log in to bookmark issues
icon_project.png Arduino Makefile / Closed Feature request #6 Assembler as is chosen rather than avr-as
action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
Go to the next issue (open or closed)
Go to the next open issue
This issue has been closed with status "Closed" and resolution "RESOLVED".
Issue basics
  • Type of issue
    Feature request
  • Targetted for
    Not determined
  • Status
    Closed
  • Progress
  • Priority
    Not determined
User pain
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
Affected by this issue (0)
There are no items
People involved
Times and dates
  • Posted at
  • Last updated
Issue details
  • Resolution
    RESOLVED
Attachments (0)
There is nothing attached to this issue
Duplicate issues (0)
This issue does not have any duplicates
Description
for assembler files (.s) arduino.ml uses 'as', which is the hosts's (x86) assembler, whereas avr-as in the avr toolchain should be used.

I don't know how to make a patch script, but in my arduino.mk I added (at appropriate places)

near CC := $(call findsoftware,avr-gcc) added AS := $(call findsoftware,avr-as)

near CPPDEPFLAGS = -MMD -MP -MF .dep/$<.dep added ASDEPFLAGS = .dep/$<.dep

near %.o: %.c .... added
%.o: %.s
mkdir -p .dep/$(dir $<)
$(COMPILE.s) $(ASDEPFLAGS) -o $@ $<

(I haven't yet been able to assemble and upload anything, so I guess I don't know what I'm doing yet, so take this is a suggestion at best :-)
Todos (0 / 0)
Issue created
May 30, 2013 (08:25)



Don't worry about URLs - they will automatically be transformed to links.
See more formatting tips in MarkdownFormatting.

To specify bold text put text between two stars, and for underlines put text between two underscores.
See more formatting tips in MarkdownFormatting.

To auto-link to an existing issue, write "issue", "bug", "ticket" or the issue type (like "bug report" or "enhancement") followed by the issue number (ex: "ticket #3" or "bug report MYPROJ-1"). Enclose sourcecode samples in <source></source> tags.
See more formatting tips in WikiFormatting.

Cancel
Hm. Don't invest time in this: avr-gcc is able to handle assembler files as well, so I'm not sure why I'm getting 'as' error messages. I will report here when I understand what the problem is (if any). Don't know how to retract this issue until then.



Don't worry about URLs - they will automatically be transformed to links.
See more formatting tips in MarkdownFormatting.

The Bug Genie uses an enhanced flavor of the markdown syntax, which makes each newline count. If you want to add a linebreak, add a new line and it will be presented just like you type.
See more formatting tips in MarkdownFormatting.

The Bug Genie will automatically add new lines when you add two new lines in your text, whereas one new line is used for formatting as you type. To force a new line, use the <br> tag: "There is a new<br>line here".
See more formatting tips in WikiFormatting.

Cancel
Should be fixed by r88

The issue was updated with the following change(s):
  • This issue has been closed
  • The status has been updated, from New to Closed.
  • This issue's progression has been updated to 100 percent completed.
  • The resolution has been updated, from Not determined to RESOLVED.
footer_logo.png The Bug Genie 4.3.1 | Support | Feedback spinning_16.gif