dev.ed.am
Arduino Makefile
Go to the previous open issue
Go to the previous issue (open or closed)
star_faded.png
Please log in to bookmark issues
icon_project.png Arduino Makefile / Closed Bug report #5 The arduino.mk file does not work with Arduino 1.5.2.
action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
Go to the next issue (open or closed)
Go to the next open issue
This issue has been closed with status "Closed" and resolution "RESOLVED".
Issue basics
  • Type of issue
    Bug report
  • Targetted for
    0.6 release
  • Status
    Closed
  • Progress
  • Priority
    Not determined
User pain
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
Affected by this issue (0)
There are no items
People involved
Times and dates
  • Posted at
  • Last updated
Issue details
  • Resolution
    RESOLVED
  • Reproducability
    Always
  • Severity
    Not determined
Attachments (1)
Duplicate issues (0)
This issue does not have any duplicates
Description
I don't know if this should be a bug or a feature request, but the current version of the arduino.mk does not work on the Arduino 1.5.2. It seems they have added an optional subsystem names 'sam' as opposed to 'avr'. This caused some directories to be moved around within the arduino IDE. I have a patch that fixes this, but this bug report system doesn't seem to let me attach the patch file.

Here is a link to the patch: [[http://tetrasys-design.net/upload/arduino.mk.patch|http://tetrasys-design.net/upload/arduino.mk.patch]]

Carl
Steps to reproduce this issue
Try to use with the Arduino 1.5.2 IDE.
Todos (0 / 0)
Issue created



Don't worry about URLs - they will automatically be transformed to links.
See more formatting tips in MarkdownFormatting.

The Bug Genie uses an enhanced flavor of the markdown syntax, which makes each newline count. If you want to add a linebreak, add a new line and it will be presented just like you type.
See more formatting tips in MarkdownFormatting.

To auto-link to an existing issue, write "issue", "bug", "ticket" or the issue type (like "bug report" or "enhancement") followed by the issue number (ex: "ticket #3" or "bug report MYPROJ-1"). Enclose sourcecode samples in <source></source> tags.
See more formatting tips in WikiFormatting.

Cancel
A file was uploaded. Carl&#039;s patch



To auto-link to an existing issue, write "issue", "bug", "ticket" or the issue type (like "bug report" or "enhancement") followed by the issue number (ex: "ticket #3" or "bug report MYPROJ-1"). Enclose sourcecode samples between two "~~~~" lines.
See more formatting tips in MarkdownFormatting.

Don't worry about URLs - they will automatically be transformed to links.
See more formatting tips in MarkdownFormatting.

URLs will be automatically transformed to links. If you want to add a title, use the link formatter: [[http://awesome.com/something An awesome link]].
See more formatting tips in WikiFormatting.

Cancel
The issue was updated with the following change(s):
  • The milestone has been updated, from Not determined to 0.6 release.
  • The status has been updated, from New to Being worked on.
  • Information about the user working on this issue has been changed, from Not being worked on to edam.



Don't worry about URLs - they will automatically be transformed to links.
See more formatting tips in MarkdownFormatting.

Don't worry about URLs - they will automatically be transformed to links.
See more formatting tips in MarkdownFormatting.

You can use simple formatting tags for underlined text (<b></b>) or strikethrough (<strike></strike>).
See more formatting tips in WikiFormatting.

Cancel
Thanks Carl, I've attached the patch. (Dunno why TBG wouldn't let you upload it -- it's got an incredibly complex permissions system, which I've checked, and regular users should be able to upload files. Perhaps it's a bug! It wouldn't be the first I've found.)

Incidentally, I'd realised that the makefile wouldn't work with the new 1.5 library, which is required to use the new Arduino Duo (which is ARM-based, and is the reason for the subsystem stuff). But, stupidly, I was thinking that I would need to get hold of an Arduino Duo to get it working. For some reason it hadn't occurred to me to test the makefile with the 1.5 library for all the usual Arduinos! Doh!
May 12, 2013 (21:20)



Don't worry about URLs - they will automatically be transformed to links.
See more formatting tips in MarkdownFormatting.

To create a bulleted list, start one or more lines with a star ("* bulleted list item"). You can create a numbered list by using the hash/pund sign instead ("# numbered list item").
See more formatting tips in MarkdownFormatting.

To auto-link to an existing issue, write "issue", "bug", "ticket" or the issue type (like "bug report" or "enhancement") followed by the issue number (ex: "ticket #3" or "bug report MYPROJ-1"). Enclose sourcecode samples in <source></source> tags.
See more formatting tips in WikiFormatting.

Cancel
Edam,

After I wrote the fix, that's in my patch file, I realized that the directory selection could have been automated. This would obviously make the whole process invisible to the end used and then the SUBSYSTEM variable would not be needed.

I'm not getting your replies in email. I'll look around the system to see if it shut off for some reason.

Thanks, Carl

edam wrote:
Thanks Carl, I've attached the patch. (Dunno why TBG wouldn't let you
upload it -- it's got an incredibly complex permissions system, which I've
checked, and regular users should be able to upload files. Perhaps it's a
bug! It wouldn't be the first I've found.)

Incidentally, I'd realised that the makefile wouldn't work with the new 1.5
library, which is required to use the new Arduino Duo (which is ARM-based,
and is the reason for the subsystem stuff). But, stupidly, I was thinking
that I would need to get hold of an Arduino Duo to get it working. For
some reason it hadn't occurred to me to test the makefile with the 1.5
library for all the usual Arduinos! Doh!





Don't worry about URLs - they will automatically be transformed to links.
See more formatting tips in MarkdownFormatting.

The Bug Genie uses an enhanced flavor of the markdown syntax, which makes each newline count. If you want to add a linebreak, add a new line and it will be presented just like you type.
See more formatting tips in MarkdownFormatting.

If you have certain text you don't want to be formatted, enclose it in <nowiki></nowiki> tags: "'''formatted''' text <nowiki>'''non-formatted''' text</nowiki>.
See more formatting tips in WikiFormatting.

Cancel
I have added initial support for the Arduino 1.5.x software. It should work with all Arduinos except the new Due (building with the new `sam` backend isn't supported yet -- see bug 9).

Any feedback from testing the latest development version of the makefile will be greatly appreciated.

The issue was updated with the following change(s):
  • This issue has been closed
  • The status has been updated, from Being worked on to Closed.
  • This issue's progression has been updated to 100 percent completed.
  • The resolution has been updated, from Not determined to RESOLVED.
  • Information about the user working on this issue has been changed, from edam to Not being worked on.
footer_logo.png The Bug Genie 4.3.1 | Support | Feedback spinning_16.gif