dev.ed.am
Arduino Makefile
Go to the previous open issue
Go to the previous issue (open or closed)
star_faded.png
Please log in to bookmark issues
icon_project.png Arduino Makefile / Closed Bug report #12 mkdir -p .dep/./ fails on OSX Mavericks
action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
Go to the next issue (open or closed)
Go to the next open issue
This issue has been closed with status "Closed" and resolution "RESOLVED".
Issue basics
  • Type of issue
    Bug report
  • Targetted for
    0.6 release
  • Status
    Closed
  • Progress
  • Priority
    Not determined
User pain
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
Affected by this issue (0)
There are no items
People involved
Times and dates
  • Posted at
  • Last updated
Issue details
  • Resolution
    RESOLVED
  • Reproducability
    Always
  • Severity
    Critical
Attachments (0)
There is nothing attached to this issue
Duplicate issues (0)
This issue does not have any duplicates
Description
Machine: Macbook Pro running OSX 10.9.1, (GNU)make version 3.81

In a sketch directory make fails at the %.o: %.ino rule. The line mkdir -p .dep/$(dir $<) resolves to mkdir -p .dep/./ which gets this error: "mkdir: .dep/./: No such file or directory"

I just removed the $(dir $<) part on the .ino/.pde rules.
Steps to reproduce this issue
cd into sketch directory which has this Makefile:
<source lang="php">
LIBRARIES := SPI SD
BOARD := uno
include ~/bin/arduino.mk
</source>
Then type make to produce failure.
Todos (0 / 0)
Issue created



To auto-link to an existing issue, write "issue", "bug", "ticket" or the issue type (like "bug report" or "enhancement") followed by the issue number (ex: "ticket #3" or "bug report MYPROJ-1"). Enclose sourcecode samples between two "~~~~" lines.
See more formatting tips in MarkdownFormatting.

To specify bold text put text between two stars, and for underlines put text between two underscores.
See more formatting tips in MarkdownFormatting.

URLs will be automatically transformed to links. If you want to add a title, use the link formatter: [[http://awesome.com/something An awesome link]].
See more formatting tips in WikiFormatting.

Cancel
The issue was updated with the following change(s):
  • This issue's reproduction steps has been changed



To auto-link to an existing issue, write "issue", "bug", "ticket" or the issue type (like "bug report" or "enhancement") followed by the issue number (ex: "ticket #3" or "bug report MYPROJ-1"). Enclose sourcecode samples between two "~~~~" lines.
See more formatting tips in MarkdownFormatting.

To auto-link to an existing issue, write "issue", "bug", "ticket" or the issue type (like "bug report" or "enhancement") followed by the issue number (ex: "ticket #3" or "bug report MYPROJ-1"). Enclose sourcecode samples between two "~~~~" lines.
See more formatting tips in MarkdownFormatting.

To create a bulleted list, start one or more lines with a star ("* bulleted list item"). You can create a numbered list by using the hash/pund sign instead ("# numbered list item").
See more formatting tips in WikiFormatting.

Cancel
The issue was updated with the following change(s):
  • This issue's description has been changed



To auto-link to an existing issue, write "issue", "bug", "ticket" or the issue type (like "bug report" or "enhancement") followed by the issue number (ex: "ticket #3" or "bug report MYPROJ-1"). Enclose sourcecode samples between two "~~~~" lines.
See more formatting tips in MarkdownFormatting.

To specify bold text put text between two stars, and for underlines put text between two underscores.
See more formatting tips in MarkdownFormatting.

You can use simple formatting tags for underlined text (<b></b>) or strikethrough (<strike></strike>).
See more formatting tips in WikiFormatting.

Cancel
The issue was updated with the following change(s):
  • This issue's description has been changed



To auto-link to an existing issue, write "issue", "bug", "ticket" or the issue type (like "bug report" or "enhancement") followed by the issue number (ex: "ticket #3" or "bug report MYPROJ-1"). Enclose sourcecode samples between two "~~~~" lines.
See more formatting tips in MarkdownFormatting.

To specify bold text put text between two stars, and for underlines put text between two underscores.
See more formatting tips in MarkdownFormatting.

To create a bulleted list, start one or more lines with a star ("* bulleted list item"). You can create a numbered list by using the hash/pund sign instead ("# numbered list item").
See more formatting tips in WikiFormatting.

Cancel
Another user reports this:

  mkdir -p .dep/./ fails in other directories, but mkdir -p .dep/ succeeds in the same directory
  
  however sudo mkdir -p .dep/./ worked





Don't worry about URLs - they will automatically be transformed to links.
See more formatting tips in MarkdownFormatting.

Code samples are best presented between two "~~~~"-lines. The Bug Genie can automatically apply syntax highlighting with support for over 100 languages! (<source lang="php"><?php echo "fu"; ?></source>)
See more formatting tips in MarkdownFormatting.

You can create a link directly to a wikipedia page by using the "WIKIPEDIA:" link namespace: "Here is a link to the wikipedia article about [[WIKIPEDIA:Norway|Norway]].
See more formatting tips in WikiFormatting.

Cancel
The issue was updated with the following change(s):
  • The status has been updated, from New to Confirmed.



To auto-link to an existing issue, write "issue", "bug", "ticket" or the issue type (like "bug report" or "enhancement") followed by the issue number (ex: "ticket #3" or "bug report MYPROJ-1"). Enclose sourcecode samples between two "~~~~" lines.
See more formatting tips in MarkdownFormatting.

To create a bulleted list, start one or more lines with a star ("* bulleted list item"). You can create a numbered list by using the hash/pund sign instead ("# numbered list item").
See more formatting tips in MarkdownFormatting.

The Bug Genie will automatically add new lines when you add two new lines in your text, whereas one new line is used for formatting as you type. To force a new line, use the <br> tag: "There is a new<br>line here".
See more formatting tips in WikiFormatting.

Cancel
Also, only to affects Macs. And may have just started happening after a recent Xcode update.



To auto-link to an existing issue, write "issue", "bug", "ticket" or the issue type (like "bug report" or "enhancement") followed by the issue number (ex: "ticket #3" or "bug report MYPROJ-1"). Enclose sourcecode samples between two "~~~~" lines.
See more formatting tips in MarkdownFormatting.

To create a bulleted list, start one or more lines with a star ("* bulleted list item"). You can create a numbered list by using the hash/pund sign instead ("# numbered list item").
See more formatting tips in MarkdownFormatting.

You can create a link directly to a wikipedia page by using the "WIKIPEDIA:" link namespace: "Here is a link to the wikipedia article about [[WIKIPEDIA:Norway|Norway]].
See more formatting tips in WikiFormatting.

Cancel
Yes, mkdir -p .dep/./ works fine in linux. No luck with sudo mkdir -p .dep/./ here, still fails. I'm not sure why it would make a difference since the "." directory is owned by the user.

The issue seems to be with the different mkdir. Anyone have a BSD box to check with?

By the way thanks for all your work here!

edam wrote:
Also, only to affects Macs. And may have just started happening after a
recent Xcode update.





Don't worry about URLs - they will automatically be transformed to links.
See more formatting tips in MarkdownFormatting.

The Bug Genie uses an enhanced flavor of the markdown syntax, which makes each newline count. If you want to add a linebreak, add a new line and it will be presented just like you type.
See more formatting tips in MarkdownFormatting.

If you want to put a horizontal line in the document, use four dashes: "----".
See more formatting tips in WikiFormatting.

Cancel
The issue was updated with the following change(s):
  • The milestone has been updated, from Not determined to 0.6 release.
  • The severity has been updated, from Not determined to Critical.



Don't worry about URLs - they will automatically be transformed to links.
See more formatting tips in MarkdownFormatting.

The Bug Genie uses an enhanced flavor of the markdown syntax, which makes each newline count. If you want to add a linebreak, add a new line and it will be presented just like you type.
See more formatting tips in MarkdownFormatting.

URLs will be automatically transformed to links. If you want to add a title, use the link formatter: [[http://awesome.com/something An awesome link]].
See more formatting tips in WikiFormatting.

Cancel
fixed in r96

The issue was updated with the following change(s):
  • This issue has been closed
  • The status has been updated, from Confirmed to Closed.
  • This issue's progression has been updated to 100 percent completed.
  • The resolution has been updated, from Not determined to RESOLVED.



To auto-link to an existing issue, write "issue", "bug", "ticket" or the issue type (like "bug report" or "enhancement") followed by the issue number (ex: "ticket #3" or "bug report MYPROJ-1"). Enclose sourcecode samples between two "~~~~" lines.
See more formatting tips in MarkdownFormatting.

To create a bulleted list, start one or more lines with a star ("* bulleted list item"). You can create a numbered list by using the hash/pund sign instead ("# numbered list item").
See more formatting tips in MarkdownFormatting.

The Bug Genie will automatically add new lines when you add two new lines in your text, whereas one new line is used for formatting as you type. To force a new line, use the <br> tag: "There is a new<br>line here".
See more formatting tips in WikiFormatting.

Cancel
Carl_P, this is fixed in the latest development version of the makefile, which you can get form here. If you'd mind reporting back to say if this fixes the issue for you or not, I'd really appreciate it!



To auto-link to an existing issue, write "issue", "bug", "ticket" or the issue type (like "bug report" or "enhancement") followed by the issue number (ex: "ticket #3" or "bug report MYPROJ-1"). Enclose sourcecode samples between two "~~~~" lines.
See more formatting tips in MarkdownFormatting.

The Bug Genie uses an enhanced flavor of the markdown syntax, which makes each newline count. If you want to add a linebreak, add a new line and it will be presented just like you type.
See more formatting tips in MarkdownFormatting.

To auto-link to an existing issue, write "issue", "bug", "ticket" or the issue type (like "bug report" or "enhancement") followed by the issue number (ex: "ticket #3" or "bug report MYPROJ-1"). Enclose sourcecode samples in <source></source> tags.
See more formatting tips in WikiFormatting.

Cancel
I can't get the dev version to work so I took your changes to the "mkdir" lines and put them in version 5. I've built a few sketches and it seems to work fine. Thanks. Shame we have to do it that way.

In the dev version this is the error I'm getting. I'll go back and see what the problem is and report back.

sed: 1: "s/^menu\.cpu\.uno\.buil ...": bad flag in substitute command: 'I'


BTW, I just received a DUE in the mail so I can really check out the dev version...

Thanks

edam wrote:
Carl_P, this is fixed in the latest development version of the makefile,
which you can get form here. If you'd mind reporting back to say if this
fixes the issue for you or not, I'd really appreciate it!


footer_logo.png The Bug Genie 4.3.1 | Support | Feedback spinning_16.gif