dev.ed.am
Arduino Makefile
Go to the previous open issue
Go to the previous issue (open or closed)
star_faded.png
Please log in to bookmark issues
icon_project.png Arduino Makefile / Closed Bug report #10 Using Arduino Makefile to build ArdOS results in a bad executable
action_vote_minus_faded.png
0
Votes
action_vote_plus_faded.png
Go to the next issue (open or closed)
Go to the next open issue
This issue has been closed with status "Not a bug" and resolution "NOT AN ISSUE".
Issue basics
  • Type of issue
    Bug report
  • Targetted for
    Not determined
  • Status
    Not a bug
  • Progress
  • Priority
    Not determined
User pain
  • Type of bug
    Not triaged
  • Likelihood
    Not triaged
  • Effect
    Not triaged
Affected by this issue (0)
There are no items
People involved
Times and dates
  • Posted at
  • Last updated
Issue details
  • Resolution
    NOT AN ISSUE
  • Reproducability
    Always
  • Severity
    Not determined
Attachments (0)
There is nothing attached to this issue
Duplicate issues (0)
This issue does not have any duplicates
Description
I built an example ArdOS ([https://bitbucket.org/ctank/ardos-ide/wiki/Home https://bitbucket.org/ctank/ardos-ide/wiki/Home]) code, bigExample.ino, using the Arduino Makefile, and it builds successfully but it does not execute correctly. It seems to continually jump back to the start of the code.

Building bigExample.ino in the Arduino IDE builds and runs correctly.
Steps to reproduce this issue
# Install ArdOS library from [https://bitbucket.org/ctank/ardos-ide/wiki/Home https://bitbucket.org/ctank/ardos-ide/wiki/Home] into the Arduino IDE 1.0.5

# Open the ArdOS example bigExample.ino in the Arduino IDE

# Save it as a new project.

# Add
<source>#include "ArdOS.h"</source>
to the top of the bigExample.ino file and create an empty ArdOS.h file in the same directory as bigExample.ino (to allow arduino.mk to pull in the ArdOS library).

# In the Arduino IDE, upload bigExample to an Arduino and open the serial port. Watch it display the correct data.

# In a terminal window, use the Arduino Makefile to make and upload to an Arduino. Watch it build correctly.

# Using make monitor, watch it continuously reset and not display the correct data.

Todos (0 / 0)
Issue created
Oct 23, 2013 (00:47)



To auto-link to an existing issue, write "issue", "bug", "ticket" or the issue type (like "bug report" or "enhancement") followed by the issue number (ex: "ticket #3" or "bug report MYPROJ-1"). Enclose sourcecode samples between two "~~~~" lines.
See more formatting tips in MarkdownFormatting.

Don't worry about URLs - they will automatically be transformed to links.
See more formatting tips in MarkdownFormatting.

URLs will be automatically transformed to links. If you want to add a title, use the link formatter: [[http://awesome.com/something An awesome link]].
See more formatting tips in WikiFormatting.

Cancel
Turns out this was a bug in the way ArdOS was inlining code. The compiler that I had installed and was called from arduino.mk (g++ 4.6.2) was different than the one called by the Arduino environment (g++ 4.3.2).

No fix is required for Arduino makefile.



To auto-link to an existing issue, write "issue", "bug", "ticket" or the issue type (like "bug report" or "enhancement") followed by the issue number (ex: "ticket #3" or "bug report MYPROJ-1"). Enclose sourcecode samples between two "~~~~" lines.
See more formatting tips in MarkdownFormatting.

Don't worry about URLs - they will automatically be transformed to links.
See more formatting tips in MarkdownFormatting.

If you want to put a horizontal line in the document, use four dashes: "----".
See more formatting tips in WikiFormatting.

Cancel
Thanks for following-up! :o)

The issue was updated with the following change(s):
  • The status has been updated, from New to Not a bug.
  • This issue has been closed
  • The resolution has been updated, from Not determined to NOT AN ISSUE.
  • This issue's progression has been updated to 100 percent completed.
footer_logo.png The Bug Genie 4.3.1 | Support | Feedback spinning_16.gif